package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)(?:\s|^)(Prefix:[a-zA-Z0-9][\w.-]*[^.]#\d+)(?:\s|$)`)
var str = `Prefix:middle#113 build: xxxxxx Prefix:middle#6
Prefix:middle#16026Prefix:middle#1111
Prefix:middle#110 Prefix:middle.#2 Prefix:middl.e#111 Prefix:middle#112`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}