# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/([\w\s]*(?:\([^)]*\)[\w\s]*)*)(\W)/$1\\$2/g;t' <<< "Foo (.*) bar blla (.*) b*l?a$ && bla bla "