import re
regex = re.compile(r"([\w\s]*(?:\([^)]*\)[\w\s]*)*)(\W)")
test_str = "Foo (.*) bar blla (.*) b*l?a$ && bla bla "
subst = "$1\\\\$2"
result = regex.sub(subst, test_str)
if result:
print(result)