// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"([\w\s]*(?:\([^)]*\)[\w\s]*)*)(\W)").unwrap();
let string = "Foo (.*) bar blla (.*) b*l?a$ && bla bla ";
let substitution = "$1\\\\$2";
// result will be a String with the substituted value
let result = regex.replace_all(string, substitution);
println!("{}", result);
}