import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(\\w+):\\s?(\\w+);";
final String string = " AllowMagazine: boolean;\n"
+ " Badge: string;\n"
+ " BirthDay: number;\n"
+ " Blocked: boolean;\n"
+ " BusNr: string;\n"
+ " CardQty: number;\n"
+ " CityID: number;\n"
+ " CityName: string;\n"
+ " CityZip: string;\n"
+ " CountryISOCode: string;\n"
+ " CustomerID: number;\n"
+ " DirectReduction: boolean;\n"
+ " Email: string;\n"
+ " FirstName: string;\n"
+ " Gender: string;\n"
+ " IsActive: boolean;\n"
+ " LanguageISO: string;\n"
+ " LastName: string;\n"
+ " Mailing: boolean;\n"
+ " Mobile: string;\n"
+ " Phone: string;\n"
+ " Pincode: string;\n"
+ " Reduction: number;\n"
+ " ReductionAllowed: boolean;\n"
+ " Street: string;\n"
+ " StreetNr: string;\n";
final String subst = "@property {$2} $1";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}