re = /(\w+):\s?(\w+);/m
str = ' AllowMagazine: boolean;
Badge: string;
BirthDay: number;
Blocked: boolean;
BusNr: string;
CardQty: number;
CityID: number;
CityName: string;
CityZip: string;
CountryISOCode: string;
CustomerID: number;
DirectReduction: boolean;
Email: string;
FirstName: string;
Gender: string;
IsActive: boolean;
LanguageISO: string;
LastName: string;
Mailing: boolean;
Mobile: string;
Phone: string;
Pincode: string;
Reduction: number;
ReductionAllowed: boolean;
Street: string;
StreetNr: string;
'
subst = '@property {$2} $1'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result