import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "\\/CATALOG\\/(sort-price\\/|code\\/sort-price\\/)num[0-9]{1,}\\/page[0-9]{1,}\\/";
final String string = "\n"
+ "/CATALOG/code/sort-price/num48/page2/\n\n\n"
+ "/CATALOG/sort-price/num48/page2/";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}