#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?x) \$ \w+ #variable name" & @CRLF & _
"(?:" & @CRLF & _
" (?:( \. ) #method call `.`" & @CRLF & _
" ( \S+ ) # method name" & @CRLF & _
" )?" & @CRLF & _
" ( \( ) # function open paren" & @CRLF & _
" ( .*?) # function arguments" & @CRLF & _
" ( \) ) # function close paren" & @CRLF & _
")? "
Local $sString = ""$created.url ~ "#$origin.human-kind() $origin.name()".subst(:g, /\s+/, '_')" & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")