// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?x) \$ \w+ #variable name
(?:
(?:( \. ) #method call `.`
( \S+ ) # method name
)?
( \( ) # function open paren
( .*?) # function arguments
( \) ) # function close paren
)? ").unwrap();
let string = "\"$created.url ~ \"#$origin.human-kind() $origin.name()\".subst(:g, /\\s+/, '_')
";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}