re = /(?x) \$ \w+ #variable name
(?:
(?:( \. ) #method call `.`
( \S+ ) # method name
)?
( \( ) # function open paren
( .*?) # function arguments
( \) ) # function close paren
)? /
str = '"$created.url ~ "#$origin.human-kind() $origin.name()".subst(:g, /\\s+/, \'_\')
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end