$re = '~(?x) \$ \w+ #variable name
(?:
(?:( \. ) #method call `.`
( \S+ ) # method name
)?
( \( ) # function open paren
( .*?) # function arguments
( \) ) # function close paren
)? ~';
$str = '"$created.url ~ "#$origin.human-kind() $origin.name()".subst(:g, /\\s+/, \'_\')
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);