#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "[^\[]*\[(\((?P<string>(?P<param>\%[^\%]*\%)(?P<sign>.+)(?P<condition>[^\)]+))\) \{(?P<true_string>(?P<true_output>[^\|]*)\|(?P<true_param_set>[^\}]*))\}\:\{(?P<false_string>(?P<false_output>[^\|]*)\|(?P<false_param_set>[^\}]*))\})\][^\]]*"
Local $sString = "тут какой то рандомный ненужный текст [(%RANDOM[0,1]%=0) {налево|%DIRECTION%=left}:{направо|%DIRECTION%=right&%SOME_ANOTHER_PARAM%=1}] тут какой то рандомный ненужный текст"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")