import Foundation
let pattern = #"[^\[]*\[(\((?P<string>(?P<param>\%[^\%]*\%)(?P<sign>.+)(?P<condition>[^\)]+))\) \{(?P<true_string>(?P<true_output>[^\|]*)\|(?P<true_param_set>[^\}]*))\}\:\{(?P<false_string>(?P<false_output>[^\|]*)\|(?P<false_param_set>[^\}]*))\})\][^\]]*"#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #"тут какой то рандомный ненужный текст [(%RANDOM[0,1]%=0) {налево|%DIRECTION%=left}:{направо|%DIRECTION%=right&%SOME_ANOTHER_PARAM%=1}] тут какой то рандомный ненужный текст"#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)