import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "[^\\[]*\\[(\\((?P<string>(?P<param>\\%[^\\%]*\\%)(?P<sign>.+)(?P<condition>[^\\)]+))\\) \\{(?P<true_string>(?P<true_output>[^\\|]*)\\|(?P<true_param_set>[^\\}]*))\\}\\:\\{(?P<false_string>(?P<false_output>[^\\|]*)\\|(?P<false_param_set>[^\\}]*))\\})\\][^\\]]*";
final String string = "тут какой то рандомный ненужный текст [(%RANDOM[0,1]%=0) {налево|%DIRECTION%=left}:{направо|%DIRECTION%=right&%SOME_ANOTHER_PARAM%=1}] тут какой то рандомный ненужный текст";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}