use strict;
my $str = 'тут какой то рандомный ненужный текст [(%RANDOM[0,1]%=0) {налево|%DIRECTION%=left}:{направо|%DIRECTION%=right&%SOME_ANOTHER_PARAM%=1}] тут какой то рандомный ненужный текст';
my $regex = qr/[^\[]*\[(\((?P<string>(?P<param>\%[^\%]*\%)(?P<sign>.+)(?P<condition>[^\)]+))\) \{(?P<true_string>(?P<true_output>[^\|]*)\|(?P<true_param_set>[^\}]*))\}\:\{(?P<false_string>(?P<false_output>[^\|]*)\|(?P<false_param_set>[^\}]*))\})\][^\]]*/p;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}