re = /[^\[]*\[(\((?P<string>(?P<param>\%[^\%]*\%)(?P<sign>.+)(?P<condition>[^\)]+))\) \{(?P<true_string>(?P<true_output>[^\|]*)\|(?P<true_param_set>[^\}]*))\}\:\{(?P<false_string>(?P<false_output>[^\|]*)\|(?P<false_param_set>[^\}]*))\})\][^\]]*/
str = 'тут какой то рандомный ненужный текст [(%RANDOM[0,1]%=0) {налево|%DIRECTION%=left}:{направо|%DIRECTION%=right&%SOME_ANOTHER_PARAM%=1}] тут какой то рандомный ненужный текст'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end