#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)[a-zA-Z0-9._]*@[a-zA-Z0-9-]*\.[a-z]*"
Local $sString = "name_lastname@hotmail.com" & @CRLF & _
"name.lastname@gmail.com" & @CRLF & _
"user@domainname.nl" & @CRLF & _
"user@domain-name.tld" & @CRLF & _
"help@911.com" & @CRLF & _
"party@club.amsterdam" & @CRLF & _
"toys@web.shop"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")