// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)[a-zA-Z0-9._]*@[a-zA-Z0-9-]*\.[a-z]*").unwrap();
let string = "name_lastname@hotmail.com
name.lastname@gmail.com
user@domainname.nl
user@domain-name.tld
help@911.com
party@club.amsterdam
toys@web.shop";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}