using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"[a-zA-Z0-9._]*@[a-zA-Z0-9-]*\.[a-z]*";
string input = @"name_lastname@hotmail.com
name.lastname@gmail.com
user@domainname.nl
user@domain-name.tld
help@911.com
party@club.amsterdam
toys@web.shop";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}