re = /[a-zA-Z0-9._]*@[a-zA-Z0-9-]*\.[a-z]*/m
str = 'name_lastname@hotmail.com
name.lastname@gmail.com
user@domainname.nl
user@domain-name.tld
help@911.com
party@club.amsterdam
toys@web.shop'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end