using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"""(?:[^""]+|"")*""|[^;]+|(?<=;|^)(?=;|$)";
string input = @";;""test123;weiterer Text"";;""Test mit "" Zeichen im Spaltenwert"";nächste Spalte mit "" Begrenzungszeichen;""4711"";irgendwas 123,4;1222;""foo""test"";""test;"";"";";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}