const regex = /"(?:[^"]+|"")*"|[^;]+|(?<=;|^)(?=;|$)/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('"(?:[^"]+|"")*"|[^;]+|(?<=;|^)(?=;|$)', 'g')
const str = `;;"test123;weiterer Text";;"Test mit "" Zeichen im Spaltenwert";nächste Spalte mit "" Begrenzungszeichen;"4711";irgendwas 123,4;1222;"foo""test";"test;"";";`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}