$re = '/"(?:[^"]+|"")*"|[^;]+|(?<=;|^)(?=;|$)/';
$str = ';;"test123;weiterer Text";;"Test mit "" Zeichen im Spaltenwert";nächste Spalte mit "" Begrenzungszeichen;"4711";irgendwas 123,4;1222;"foo""test";"test;"";";';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);