import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "\"(?:[^\"]+|\"\")*\"|[^;]+|(?<=;|^)(?=;|$)";
final String string = ";;\"test123;weiterer Text\";;\"Test mit \"\" Zeichen im Spaltenwert\";nächste Spalte mit \"\" Begrenzungszeichen;\"4711\";irgendwas 123,4;1222;\"foo\"\"test\";\"test;\"\";\";";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}