re = /"(?:[^"]+|"")*"|[^;]+|(?<=;|^)(?=;|$)/
str = ';;"test123;weiterer Text";;"Test mit "" Zeichen im Spaltenwert";nächste Spalte mit "" Begrenzungszeichen;"4711";irgendwas 123,4;1222;"foo""test";"test;"";";'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end