re = /(?:"([^"]*)";){3}/
str = '"/activities/absenceactivity/lang/#LANG_ID#/prop_dialog.php";"BA2_PD_SCR";"Opis dogodka";"Event description";"Descrição do Evento";"ÐÐ¿Ð¸Ñ Ð¿Ð¾Ð´Ñ Ñ";"";"č®vykio aprašymas";"Descripción del evento";"";'
# Print the match result
str.match(re) do |match|
puts match.to_s
end