// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r#"(?:"([^"]*)";){3}"#).unwrap();
let string = "\"/activities/absenceactivity/lang/#LANG_ID#/prop_dialog.php\";\"BA2_PD_SCR\";\"Opis dogodka\";\"Event description\";\"Descrição do Evento\";\"ÐÐ¿Ð¸Ñ Ð¿Ð¾Ð´ÑÑ\";\"\";\"č®vykio aprašymas\";\"Descripción del evento\";\"\";";
// result will be a tuple containing the start and end indices for the first match in the string
let result = regex.captures(string);
let (start, end) = match result {
Some((s, e)) => (s, e),
None => {
// ...
}
};
println!("{}", &string[start, end]);
}