#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^(?=[a-zA-Z0-9]{1,80}$)[a-zA-Z]+[0-9]*$"
Local $sString = "a" & @CRLF & _
"a1" & @CRLF & _
"ab12" & @CRLF & _
"aAc" & @CRLF & _
"aAd12" & @CRLF & _
"ad123456789012345678901234567890123456789012345678901234567890123456789012345678" & @CRLF & _
"ad1234567890123456789012345678901234567890123456789012345678901234567890123456782" & @CRLF & _
"1" & @CRLF & _
"1a" & @CRLF & _
"" & @CRLF & _
"a1111" & @CRLF & _
"a3333d"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")