$re = '/^(?=[a-zA-Z0-9]{1,80}$)[a-zA-Z]+[0-9]*$/m';
$str = 'a
a1
ab12
aAc
aAd12
ad123456789012345678901234567890123456789012345678901234567890123456789012345678
ad1234567890123456789012345678901234567890123456789012345678901234567890123456782
1
1a
a1111
a3333d';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);