import re
regex = re.compile(r"^(?=[a-zA-Z0-9]{1,80}$)[a-zA-Z]+[0-9]*$", flags=re.MULTILINE)
test_str = ("a\n"
"a1\n"
"ab12\n"
"aAc\n"
"aAd12\n"
"ad123456789012345678901234567890123456789012345678901234567890123456789012345678\n"
"ad1234567890123456789012345678901234567890123456789012345678901234567890123456782\n"
"1\n"
"1a\n\n"
"a1111\n"
"a3333d")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")