using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^(?=[a-zA-Z0-9]{1,80}$)[a-zA-Z]+[0-9]*$";
string input = @"a
a1
ab12
aAc
aAd12
ad123456789012345678901234567890123456789012345678901234567890123456789012345678
ad1234567890123456789012345678901234567890123456789012345678901234567890123456782
1
1a
a1111
a3333d";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}