#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)\b(?<!no\s)(?:restaurant|commerce|commercial)\b"
Local $sString = "Commerce foo" & @CRLF & _
"foo commercial" & @CRLF & _
"foo no commercial" & @CRLF & _
"foo commercial boo" & @CRLF & _
"No commerce" & @CRLF & _
"foo restaurant" & @CRLF & _
"boo no restaurant"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")