const regex = new RegExp('\\b(?<!no\\s)(?:restaurant|commerce|commercial)\\b', 'gm')
const str = `Commerce foo
foo commercial
foo no commercial
foo commercial boo
No commerce
foo restaurant
boo no restaurant`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}