import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "\\b(?<!no\\s)(?:restaurant|commerce|commercial)\\b";
final String string = "Commerce foo\n"
+ "foo commercial\n"
+ "foo no commercial\n"
+ "foo commercial boo\n"
+ "No commerce\n"
+ "foo restaurant\n"
+ "boo no restaurant";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}