re = /\b(?<!no\s)(?:restaurant|commerce|commercial)\b/m
str = 'Commerce foo
foo commercial
foo no commercial
foo commercial boo
No commerce
foo restaurant
boo no restaurant'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end