using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"\b(?<!no\s)(?:restaurant|commerce|commercial)\b";
string input = @"Commerce foo
foo commercial
foo no commercial
foo commercial boo
No commerce
foo restaurant
boo no restaurant";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}