package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)\w(\d+_\d+_)\w+`)
var str = `S1_2_S1_test.txt
S2_2_S18_test.txt
S3_2_S9_test.txt`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}