// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)\w(\d+_\d+_)\w+").unwrap();
let string = "S1_2_S1_test.txt
S2_2_S18_test.txt
S3_2_S9_test.txt";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}