$re = '/\w(\d+_\d+_)\w+/m';
$str = 'S1_2_S1_test.txt
S2_2_S18_test.txt
S3_2_S9_test.txt';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);