re = /\w(\d+_\d+_)\w+/m
str = 'S1_2_S1_test.txt
S2_2_S18_test.txt
S3_2_S9_test.txt'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end