package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^(?<mID>24)(?<moduleID>[1-6])(((?<dlc>4)(?<payload>[0-9A-F]{8}))|((?<dlc>7)(?<payload>[0-9A-F]{14}))|((?<dlc>1)(?<payload>[0-9A-F]{2}))|((?<dlc>3)(?<payload>[0-9A-F]{6})))$`)
var str = `2413000101`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}