$re = '/^(?<mID>24)(?<moduleID>[1-6])(((?<dlc>4)(?<payload>[0-9A-F]{8}))|((?<dlc>7)(?<payload>[0-9A-F]{14}))|((?<dlc>1)(?<payload>[0-9A-F]{2}))|((?<dlc>3)(?<payload>[0-9A-F]{6})))$/m';
$str = '2413000101';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);