// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)^(?<mID>24)(?<moduleID>[1-6])(((?<dlc>4)(?<payload>[0-9A-F]{8}))|((?<dlc>7)(?<payload>[0-9A-F]{14}))|((?<dlc>1)(?<payload>[0-9A-F]{2}))|((?<dlc>3)(?<payload>[0-9A-F]{6})))$").unwrap();
let string = "2413000101";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}