import Foundation
let pattern = #"^(?<mID>24)(?<moduleID>[1-6])(((?<dlc>4)(?<payload>[0-9A-F]{8}))|((?<dlc>7)(?<payload>[0-9A-F]{14}))|((?<dlc>1)(?<payload>[0-9A-F]{2}))|((?<dlc>3)(?<payload>[0-9A-F]{6})))$"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"2413000101"#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)