import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^(?<mID>24)(?<moduleID>[1-6])(((?<dlc>4)(?<payload>[0-9A-F]{8}))|((?<dlc>7)(?<payload>[0-9A-F]{14}))|((?<dlc>1)(?<payload>[0-9A-F]{2}))|((?<dlc>3)(?<payload>[0-9A-F]{6})))$";
final String string = "2413000101";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}