import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "q$|^w";
final String string = "weekend\n"
+ "hello\n"
+ "yummy\n"
+ "working\n"
+ "seq\n"
+ "sequence\n"
+ "bird\n"
+ "puzzle\n"
+ "wholesome";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE | Pattern.DOTALL);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}