re = /q$|^w/m
str = 'weekend
hello
yummy
working
seq
sequence
bird
puzzle
wholesome'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end