# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/\bn(?=[A-Z0-9])//gm;t' <<< "nFamily n49 new nTom"