const regex = /\bn(?=[A-Z0-9])/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('\\bn(?=[A-Z0-9])', 'gm')
const str = `nFamily n49 new nTom`;
const subst = ``;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);