import re
regex = re.compile(r"\bn(?=[A-Z0-9])", flags=re.MULTILINE)
test_str = "nFamily n49 new nTom"
subst = ""
result = regex.sub(subst, test_str)
if result:
print(result)